Dell XPS M1210 Blank Screen Problem Revisited

I think I may have come across the true cause of the blank screen problem with my Dell XPS M1210 laptop.

I was *this* close to wiping the whole HDD and starting from scratch, but I just kept putting it off. After a while of using my laptop every day or so, I noticed two things: 1. the screen was not going black at the Windows login as often anymore, and 2. I noticed myself developing a superstitious habit regarding the wireless mouse (a Microsoft Wireless Notebook Optical Mouse 3000).

Now, superstitions often arise in human behavior when the mind subconsciously creates a cause-and-effect link between two normally unrelated things. Sometimes this link is wrong, but sometimes it is right. Some scientists speculate that this special kind of adaptation to non-obvious dangers may even be evolutionarily advantageous.

Anyway, knowing that I had suddenly developed a mild superstition, and knowing that this could mean my brain had discovered a link that I was not yet consciously aware of, I began paying more attention to what I was doing when I was getting the blank screen on my laptop.

After a while, I noticed that the screen black-outs almost always occurred when I plugged the mouse in before turning the laptop on. This also reminded me of the fact that this issue most often occurred after I had packed away my laptop and set it up again (meaning I was unplugging the mouse and plugging it back in).

This morning I was having a lot of trouble with my mouse freezing up. The battery was getting low — not so low that it stopped working, but low enough that it would sometimes stop working, even though the infrared LED was still on. Sometimes control of the mouse would return (with some coercion), sometimes it wouldn’t.

What I think has been happening is that the mouse may have been flaking out at a certain point during the bootup sequence, causing the laptop display drivers to screw up and put the screen in “sleep mode”, turning it black.

So far today, with a fresh battery in the mouse, the problem has not returned. We’ll see if this lasts.

Update: So far, the plugging-in-the-wireless-mouse-partway-into-the-bootup-process method has been working for me.  It’s been a while since I’ve encountered the Black Screen of Dell.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s